Go Back   AudiWorld Forums > Audi Models > Audi A6 / S6 / RS 6 > A6 / S6 (C5 Platform) Discussion
Sign in using an external account
Register Forgot Password?

Notices

A6 / S6 (C5 Platform) Discussion Discussion forum for the C5 Audi A6 and S6 produced from 1998-2004

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 12-25-2013, 01:07 AM   #1
suomis
AudiWorld Newcomer
Account #: 182496
 
Join Date: Apr 2010
Posts: 2
Default not heating properly audi a6 1,9tdi , 1999

My 1999 Audi A6 blows cold air even when the engine is hot. The only way that I can get any warm air in the cabin is to set both thermostats to Hi, have the defrost on front window and have the heater in econ mode. Even then it only blows moderately warm air and not enough to heat the cabin. Any ideas on what is causing this?
suomis is offline   Reply With Quote
Old 12-25-2013, 04:47 AM   #2
GTA_Driver
AudiWorld Super User
Account #: 80057
 
GTA_Driver's Avatar
 
Join Date: Aug 2004
Location: Toronto
Posts: 3,276
Default

Flush the heater core. If it doesn't help, you may need to replace it. A cheap part but a lot of labour.
GTA_Driver is offline   Reply With Quote
Old 12-25-2013, 12:08 PM   #3
tester123
AudiWorld Member
Account #: 171699
 
tester123's Avatar
 
Join Date: Oct 2009
Posts: 487
Default

Quote:
Originally Posted by GTA_Driver View Post
Flush the heater core. If it doesn't help, you may need to replace it. A cheap part but a lot of labour.
Do you have any coolant leaks? Air could be trapped in the system.
As GTA_Driver mentioned, system flush is the best option.

Also, try to drive up a very steep/inclined road and check/add coolant. Then drive Down the same and check/add coolant. I did this few times and got all the air out quickly. The best way really is to drive around, keep checking coolant level, open the reservoir cap (when cold) and add more coolant until level no longer drops.

The other possibility is that flaps that direct air through the heater core are not operating properly/stuck.
__________________
ʘ˥ Pearl White А6 Ч.2ℓ Quattro
Sport, cold, everything -Nav.
▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫
No more OIL or COOLANT leaks! │ T-Belt, Water pump & Valve Covers DONE! │ Trans & Diff Fluid DONE! │ Bearing & Inner Tie-rod Next │ Steering leaks?
Fuel Banks 1 & 2 Lean issue fixed (finally!)
Rebuild Bosch 150 Amp Alternator (save major $$$)
tester123 is offline   Reply With Quote
Old 12-28-2013, 07:26 PM   #4
wshymas
Audiworld Junior Member
Account #: 273744
 
Join Date: Dec 2013
Posts: 10
Default

I had the same problem on my 02 A6. I used some red rubber hose to hook the heater core to the steam cleaner at work flushed both ways. I also filled the core with CLR and let it sit for 5-10 min the flushed with water. Refilled the cooling system and now I have heat.
wshymas is offline   Reply With Quote
Old 12-28-2013, 11:46 PM   #5
suomis
AudiWorld Newcomer
Account #: 182496
 
Join Date: Apr 2010
Posts: 2
Default

Thank You for advice,will try .
suomis is offline   Reply With Quote
Old 12-28-2013, 11:46 PM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
a6, audi, heat, sitting, warm


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -8. The time now is 12:47 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community

Personal Contacts