Go Back   AudiWorld Forums » Audi Models » Audi S4 / RS4 » S4 (B6 & B7 Platforms) Discussion
Sign in using an external account
Register Forgot Password?

Welcome to AudiWorld!
Welcome to AudiWorld.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join AudiWorld.com today!


Notices

S4 (B6 & B7 Platforms) Discussion Discussion forum for the B6 Audi S4 produced from 2003-2005 And B7 Audi S4 produced from 2005 -2008

Discussion Forums:
Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-06-2011, 03:09 PM   #1
s4_sp
Audiworld Junior Member
2005 Audi S4
 
Join Date: Dec 2005
Posts: 33
Default air conditioner stops working after about 2 hours.

Hello,
The air conditioner in my S4 usually works fine. But it stops working after about 1-2 hours driving, (when I have a long hour road trip.)

At the beginning it works very fine, but after about 1 hour later, the air flow from the vent becomes getting weaker and after another 30 min later eventually the cold air flow stops, instead there is only weak warm air coming out from the vent.

I could see that the A/C works again after I stop the engine and cool down the engine for a while.

This morning, the A/C works fine "again" for my 30 min commuting, so it is really hard to reproduce the problem. Anyway, I'll bring my S4 to the dealer.

Please give me any advices, I appreciate them.
Thanks much in advance.
s4_sp is offline   Reply With Quote
Old 07-17-2011, 05:46 AM   #2
QIKRNU
AudiWorld Newcomer
Garage is empty, add now
 
Join Date: Jul 2011
Location: East ofCincinnati
Posts: 5
Default

Quote:
Originally Posted by s4_sp View Post
Hello,
The air conditioner in my S4 usually works fine. But it stops working after about 1-2 hours driving, (when I have a long hour road trip.)

At the beginning it works very fine, but after about 1 hour later, the air flow from the vent becomes getting weaker and after another 30 min later eventually the cold air flow stops, instead there is only weak warm air coming out from the vent.

I could see that the A/C works again after I stop the engine and cool down the engine for a while.

This morning, the A/C works fine "again" for my 30 min commuting, so it is really hard to reproduce the problem. Anyway, I'll bring my S4 to the dealer.

Please give me any advices, I appreciate them.
Thanks much in advance.
It sounds like your evaporator is icing up. Mine did this once. Just press the "Econ" button and the ice will melt in a few minutes and you will have cold again. Also check your cabin air filter. If it is very dirty, you may not be getting enough air flow to keep from icing up.
QIKRNU is offline   Reply With Quote
Old 07-21-2011, 09:24 AM   #3
xtreeme
Audiworld Junior Member
2005 Audi S4
 
xtreeme's Avatar
 
Join Date: Aug 2010
Location: Wisconsin
Posts: 21
Default

I have the same problem that just started last week (about the same time as the 100+ humid temps came around here). My A/C starts to cut out after about a half hour. I thought it was just the hot humid air making it feel warmer, but now will check all the air intakes for blockage.
xtreeme is offline   Reply With Quote
Old 08-09-2011, 06:58 PM   #4
Audi Baron
Audiworld Junior Member
2004 Audi S4
 
Join Date: May 2011
Posts: 11
Default

i had this happen to me as well. I left the car on turned the heater on and replaced my extremely dirty cabin fiter. it works perfect now. i also found that i needed to charge my refrigerant to a higher pressure (55psi) than stock pressure. that has made everything a lot colder too.
Audi Baron is offline   Reply With Quote
Old 08-19-2011, 06:20 AM   #5
xtreeme
Audiworld Junior Member
2005 Audi S4
 
xtreeme's Avatar
 
Join Date: Aug 2010
Location: Wisconsin
Posts: 21
Default Evaporator is the issue

Just an update for those of you who are still trying to figure out what is wrong.

I took mine in to my local independent Audi service shop this week for a look see. After a half hour of monitoring on the laptop, it appears to be the Evaporator in the A/C unit. It tends to get blocked internally within the air chamber that monitors how cold the air flowing to the vents is. This blockage creates a false reading to the Evap sensor, and makes it think it is colder in the cabin than what it really is.

There is no way to actually fix the blockage issue, and it turns into a replacement job, which is quite complicated (as most Audi service jobs are) and involves removing the dash and other components to get to the actual unit for removal and replacement. (probably about $2k job for those without an extended warranty).

There are a few temporary work arounds if you do not want to spent that kind of $$$ immediately, like turning the A/C to Economy for a few minutes to let the air canister capacity reset, or you can keep lowering the temp gauge in the car when the cool air starts cutting out which will keep it cooler for a little longer, or you can also extend the cool air by keeping the air flow at a lower level, thereby allowing the air canister to keep a more regulated air temp in the blockage area for a longer period of time.

All of these kind of defeat the purpose of having an Auto Climate Control.
xtreeme is offline   Reply With Quote
Old 12-26-2011, 09:37 PM   #6
Audi Baron
Audiworld Junior Member
2004 Audi S4
 
Join Date: May 2011
Posts: 11
Default

this is my experience: the blockage is caused by ice build up from not enough air flowing past the refrigerant coils. just make sure you have a clean cabin filter. and if you get build up still then just pull over. role down your windows and turn on the heat for about 5-10min and watch the water pour from the air chamber. i had about 2 gallons of water melt off. after changing my filter i didn't have another ice up all summer.
Audi Baron is offline   Reply With Quote
Old 12-26-2011, 09:37 PM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
30, ac, air, airflow, car, conditioner, conditionig, driving, hot, hour, hours, min, stop, stops, working




Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Discussion Forums:


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2009 AudiWorld.com Audi Enthusiast Community

Personal Contacts