Go Back   AudiWorld Forums > Audi Models > Audi A6 / S6 / RS 6 > A6 / S6 (C5 Platform) Discussion
Sign in using an external account
Register Forgot Password?

Notices

A6 / S6 (C5 Platform) Discussion Discussion forum for the C5 Audi A6 and S6 produced from 1998-2004

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 06-06-2011, 01:17 PM   #1
Kerouac56
Audiworld Junior Member
Account #: 209644
 
Join Date: Mar 2011
Location: Chicago
Posts: 14
Default OIl light on 2003 A6 3.0 quattro

My oil light comes on once the car is driven for a 4 or 5 miles and is up to operating temp. Checked oil and it is at proper level.
Has anyone ever heard that this can be caused by the seals in the oil pump pickup being old and deforming once the engine reaches operating temp. Basically the oil pressure is fine (no warning light) unitl the engine heats up and the old oil pump pickup seals deform lowering the pressure which causes the oil light to illuminate. Audi mechanic told me this on the phone).

If someone is aware of this problem, and has done the oil pump pickup seals, is it very diffcult to drop the oil pan and replace the oil pump pickup seals?

Help is greatly appreciated.

Sincerely,
Kerouac56
Chicago
Kerouac56 is offline   Reply With Quote
Old 06-06-2011, 02:41 PM   #2
x19
AudiWorld Member
Account #: 213330
 
Join Date: May 2011
Posts: 125
Default OIL light on 2003 A6 3.0 quattro

well, you can remove the lower oil pan (AVK engine)and reach to oil pump mechanism. You have to prepare the required parts if you are going to such a oil pan gasket (RTV= 02 sensor free) , 6 qts Oil and maybe seal?, oil bucket and Tools of course. sorry, I never done before but,

Before, you start engine after your work finished, it's better to prime engine oil to system with disable the system includes removing spark plug, kill the spark and fuel pump circuit etc. Or you can use remote control switch, connect to starter solenoid and the other end to battery positive with remove spark plug and push remote switch few times within ten second or more time. Also, you can confirm oil pressure with test light for oil lubrication system and If every thing Ok, now you can go inside of car and start the engine. Priming engine oil is most important task when you worked on bottom of engine. x19
x19 is offline   Reply With Quote
Old 06-06-2011, 04:00 PM   #3
SloopJohnB@mac.com
AudiWorld Super User
Account #: 44417
 
SloopJohnB@mac.com's Avatar
 
Join Date: Oct 2002
Posts: 5,038
Default

Do not do anything until you confirm that you in fact have low oil pressure. It will take a mechanical pressure tap or an electrical sender (mechanical often easier). If in fact you do not have low oil pressure then you have a failed electrical switch. Replace it if necessary.

I guess it's possible for oil seals in the pickup to leak, allowing pump to ingest air and drop oil pressure...that would be a severe engine-threatening drop, BTW.

More likely you simply have a plugged oil pickup screen...once you confirm pressure is in fact low then drop the pan and see what's what. If you have to replace the oil pickup seal you could do it then.

I've used "The Right Stuff" as engine oil pan gasket vice the OEM Audi tube-O-delight that you can also get from the dealer. They're not kidding; you have about 5-10 minutes to apply the goo in a 1/8" or so bead around the pan AND around the bolt holes and install it. The spacers in the bolt holes in the pan are there to prevent deforming the pan...a torque wrench is a must. Don't use a 1/2" drive torque wrench..it's very inaccurate at the low torque setting for the pan bolts.
SloopJohnB@mac.com is offline   Reply With Quote
Old 06-08-2011, 01:13 PM   #4
Kerouac56
Audiworld Junior Member
Account #: 209644
 
Join Date: Mar 2011
Location: Chicago
Posts: 14
Default

"More likely you simply have a plugged oil pickup screen...once you confirm pressure is in fact low then drop the pan and see what's what. If you have to replace the oil pickup seal you could do it then."

I decided to go ahead and drop the oil pan. The oil pickup screen is clogged with oil junk. Moreover, the entire oil pan has 3/8 inch of funky oil gunk stuck to the bottom. I think that I found my low oil pressure light problem. Honestly, I haven't seen such a gunked up oil pan since I was in my High School auto shop classes and we had to tear down old junkyard engines. This 2003 A6 with 3.0 engine has only 87,000 miles. Plenty of time apparently for the pan to look like a gunked up mess).

(I have the complete dealership service records for this car. It appears that the people that I bought it from, only had the oil changed every 10,000 miles by the dealership. I bought the car not running with ruined cylinder heads that I just replaced. I drove the car five miles into town after running it for 45 minutes in the driveway. A few blocks from home the oil light came on, then went off. As I pulled into the driveway, the oil light came on again, then off. I figure that driving the car on streets 40 to 50 mph, and taking turns, stirred up all the gunk on the bottom of the oil pan, clogging the pickup and maybe the filter also.)

I am going to clean the entire pan and pickup screen and refill with new synthetic oil and new filter.

Another question, on the 3.0 AVK motor, how does one remove the oil pump pickup screen? Do I have to remove the entire oil pump assembly in order to remove the pickup screen?

Again, thanks for the helpful responses.

Kerouac56
Chicago
Kerouac56 is offline   Reply With Quote
Old 06-27-2011, 07:37 AM   #5
x19
AudiWorld Member
Account #: 213330
 
Join Date: May 2011
Posts: 125
Default OIl light on 2003 A6 3.0 quattro

This is not hard work after remove the lower oil pan and you can see the condition. So you can use the vacuum cleaner to remove the stuff (debris) that you see on the screen maybe and priming oil after filled up. When you start the engine without priming oil, you will hear knocking noise from bottom end with high RPM and it's too late to prevent this problem.

All engine are making the debris from internal parts and we have to change filter because, we can't remove these kind of trouble maker today unless we use oil cleaning device on engine ( Please see the "your iMPG" in forums) other wise we will have the same problem like TURBO failure and VVt code and sludge problems etc, good luck. x19
x19 is offline   Reply With Quote
Old 06-27-2011, 07:37 AM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
2003, 30, a4, a6, allroad, audi, engine, light, liter, low, oil, pressure, problem, quatrro, sympol


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -8. The time now is 09:49 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community

Personal Contacts