Go Back   AudiWorld Forums > Audi Models > Audi A6 / S6 / RS 6 > A6 / S6 (C6 Platform) Discussion
Sign in using an external account
Register Forgot Password?

Notices

A6 / S6 (C6 Platform) Discussion Discussion forum for the C6 Audi A6 produced from 2004-present and Audi S6 produced from 2007-present

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 03-22-2011, 12:47 PM   #1
05A632
AudiWorld Member
Account #: 169598
 
Join Date: Sep 2009
Posts: 128
Default How to replace Parking Brake Wiring Harnesses?

Brought my 05 A6 into the dealer today because my Parking Brake Malfunction light was on. They called and stated that there was corrosion in the harnesses, which is common, and they both needed to be replaced to the tune of $1,239. Apparently it's a bit of work, with a specified 8 hours of labor.

Anyways, I think I would light the car on fire before I dropped that much money into it for something that I have never used, especially when the parking brake still works properly and the only annoyance is the light on the dash.

Does anyone have a how-to for replacing this harness that they could share with me? I will tackle it myself over the weekend.

Thanks in advance.
05A632 is offline   Reply With Quote
Old 03-22-2011, 01:23 PM   #2
am_ver
AudiWorld Senior Member
Account #: 161252
 
Join Date: Apr 2009
Location: NorCal, USA
Posts: 1,347
Default

Well - I am not 100% sure if the wiring harness is really your problem. I had the same issue when an indy replaced my rear pads. The PB worked (engaged/disengaged) - but the P with a slash appeared on the dash. This was just months after the dealer had replaced the PB control module (before software update was failing when they were doing it for a TSB). The indy guy said he removed the battery overnight and let it discharge. Next day the error was gone.
__________________
2006 A6 3.2 Quattro, Midnight blue/beige, Nav (retrofit), Koni FSD + Eibach springs,V1 hardwired (fusebox) - CD on dash, LED DRL, K-MACS, RS Style grill.
You can't call me a badge-ho - I'm de-BADGED!
Past:
2008 BMW 335i convertible (e93); 2007 BMW 335i coupe (e92); 2006 BMW 325i sedan (e90)

Banned from QuattroWorld
am_ver is offline   Reply With Quote
Old 03-22-2011, 02:39 PM   #3
05A632
AudiWorld Member
Account #: 169598
 
Join Date: Sep 2009
Posts: 128
Default

Quote:
Originally Posted by am_ver View Post
Well - I am not 100% sure if the wiring harness is really your problem. I had the same issue when an indy replaced my rear pads. The PB worked (engaged/disengaged) - but the P with a slash appeared on the dash. This was just months after the dealer had replaced the PB control module (before software update was failing when they were doing it for a TSB). The indy guy said he removed the battery overnight and let it discharge. Next day the error was gone.
Thanks for the idea. I thought there were downsides to disconnecting the battery? Or am I wrong?
05A632 is offline   Reply With Quote
Old 04-24-2013, 08:25 AM   #4
deadcandance
AudiWorld Newcomer
Account #: 181930
 
deadcandance's Avatar
 
Join Date: Apr 2010
Posts: 9
Default

Quote:
Originally Posted by 05A632 View Post
Thanks for the idea. I thought there were downsides to disconnecting the battery? Or am I wrong?
Can anyone reply to this persons concern about disconnecting a battery to a 2005 - 2006 A6 or A8 Audi? Will that do any harm to the MMI or cause extra work and cost resetting stuff or reconfiguring the MMI or any other part of the car?
deadcandance is offline   Reply With Quote
Old 04-24-2013, 08:28 AM   #5
bazery
Audiworld Junior Member
Account #: 236665
 
Join Date: May 2012
Posts: 35
Default

I was quoted 285 euro per cable from the park brake module. its less than 2 feet long, shocked
bazery is offline   Reply With Quote
Old 04-24-2013, 08:35 AM   #6
deadcandance
AudiWorld Newcomer
Account #: 181930
 
deadcandance's Avatar
 
Join Date: Apr 2010
Posts: 9
Default

I own a 2006 A8L and have had the yellow Parking brake warning light malfunction with the circle and line through it and have had this light for 10 minths now. I have not touched my emergency parking brake since the light came on because I read that on parking barkes may engage and then be stuck on where you literally have to tow the car to the dealer for repair. So I left them alone. Is there any truth to that?

So I took the car to Burlington ON Audi and after 3 hours (!!!)(they did knock off one hour of labor thank heavens but still leaves two hours at $125.00 per hour to locate the problem ONLY) so to continue after three hours of diagnostics and searching they determined that my wiring harness between the body and the brake assembly (part#4EO 927 904 F) requires replacement. They are quoting $330.00 installed for the wiring harness replacement. I assume that is for the part and labor to install.

So guys my questions are: Does anyone know if this requires special equipment that an Audi dealer may posess or could an individual or a mechanic at a regular garage install this easily enough? Does anyone have first hand experience with these questions?

Thanks so much guys!!!!!!
deadcandance is offline   Reply With Quote
Old 04-24-2013, 08:35 AM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
05, 2005, a6, audi, brake, break, change, emergency, harness, light, located, malfunction, parking, replace, wiring


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -8. The time now is 09:47 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community

Personal Contacts