Go Back   AudiWorld Forums > Audi Models > Audi A4 > A4 (B7 Platform) Discussion
Sign in using an external account
Register Forgot Password?

Notices

A4 (B7 Platform) Discussion Discussion forum for the B7 Audi A4 produced from 2005-2008.5

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 01-21-2011, 03:56 PM   #1
audi777tom
Audiworld Junior Member
Account #: 203527
 
audi777tom's Avatar
 
Join Date: Jan 2011
Location: Skokie, IL
Posts: 11
Default Cold Start Low Oil Pressure

Today was the first really cold day the car has been in (4 degrees F high). It started fine this morning, however when leaving work there was a very severe knocking and when I hit about 2000 rpm the oil pressure light went on. I immediately stopped the car and thought it was due to the cold. So I idled for another 2-3 minutes and when I started moving it happen again. So I stopped again and checked the oil level, and it is fine. No apparent leaks. So I waited another 3 or so minutes, and took off again. Same thing happened, the oil warning light came on, but I drove through it. After about 2 minutes of driving the knocking decreased and everything seems fine, except it threw a check engine light flag. Is this just a cold start issue I have to be aware of, or something else? After driving for 15 minutes to get home I opened the hood again, and there may have been a slightly louder knock than usual, however it may just be my imagination.
Any advice is appreciated.
Thanks!
audi777tom is offline   Reply With Quote
Old 01-21-2011, 03:59 PM   #2
audi777tom
Audiworld Junior Member
Account #: 203527
 
audi777tom's Avatar
 
Join Date: Jan 2011
Location: Skokie, IL
Posts: 11
Default

Thought my Sig would show up... 2006 A4 2.0T
__________________
2006 Audi A4 2.0T
Skokie, IL
audi777tom is offline   Reply With Quote
Old 01-26-2011, 03:39 PM   #3
240sxRs4
AudiWorld Newcomer
Account #: 205308
 
Join Date: Jan 2011
Posts: 3
Default

The oil pressure light came on cause there was no oil pressure, thats different from having oil. Not good to keep driving a car with low oil pressure, although to be honest damage was prob already done once you heard the knocking noise. I'd suggest bringing the car to a shop, but would not keep driving it.


Quote:
Originally Posted by audi777tom View Post
Today was the first really cold day the car has been in (4 degrees F high). It started fine this morning, however when leaving work there was a very severe knocking and when I hit about 2000 rpm the oil pressure light went on. I immediately stopped the car and thought it was due to the cold. So I idled for another 2-3 minutes and when I started moving it happen again. So I stopped again and checked the oil level, and it is fine. No apparent leaks. So I waited another 3 or so minutes, and took off again. Same thing happened, the oil warning light came on, but I drove through it. After about 2 minutes of driving the knocking decreased and everything seems fine, except it threw a check engine light flag. Is this just a cold start issue I have to be aware of, or something else? After driving for 15 minutes to get home I opened the hood again, and there may have been a slightly louder knock than usual, however it may just be my imagination.
Any advice is appreciated.
Thanks!
240sxRs4 is offline   Reply With Quote
Old 01-03-2012, 01:49 PM   #4
06a4
AudiWorld Newcomer
Account #: 228612
 
Join Date: Jan 2012
Posts: 1
Default

Bumping as this came up in a Search and I experienced the same issue this morning (-20deg Celsius). I turned the car off and it has been sitting since. Plenty of oil.

Plan on getting it towed to the shop later this week - does anyone know what the problem could potential be? Fuel pump?

Thanks,
06a4 is offline   Reply With Quote
Old 02-20-2014, 08:42 AM   #5
RK1967
AudiWorld Newcomer
Account #: 277540
 
Join Date: Feb 2014
Posts: 1
Default

HI,

I have a very similar problem with my A4 2.0T 2007. WHen it is very cold, I have to warm up the car for 8-10 minutes before I can drive it. If I drive it, the oil light will light on.

Did you have a conclusion to your problem ?

Thanks

RK


Quote:
Originally Posted by 06a4 View Post
Bumping as this came up in a Search and I experienced the same issue this morning (-20deg Celsius). I turned the car off and it has been sitting since. Plenty of oil.

Plan on getting it towed to the shop later this week - does anyone know what the problem could potential be? Fuel pump?

Thanks,
RK1967 is offline   Reply With Quote
Old 02-26-2014, 04:12 PM   #6
audi777tom
Audiworld Junior Member
Account #: 203527
 
audi777tom's Avatar
 
Join Date: Jan 2011
Location: Skokie, IL
Posts: 11
Default

After that one occurrence I have never had that problem again. I still have the same car a few years later, and this winter has been extremely cold in Chicago. So I am still baffled as to why this happened or what caused it.
__________________
2006 Audi A4 2.0T
Skokie, IL
audi777tom is offline   Reply With Quote
Old 03-05-2014, 05:58 PM   #7
Jonboyy055
AudiWorld Newcomer
Account #: 278411
 
Join Date: Mar 2014
Posts: 3
Default

Quote:
Originally Posted by audi777tom View Post
Today was the first really cold day the car has been in (4 degrees F high). It started fine this morning, however when leaving work there was a very severe knocking and when I hit about 2000 rpm the oil pressure light went on. I immediately stopped the car and thought it was due to the cold. So I idled for another 2-3 minutes and when I started moving it happen again. So I stopped again and checked the oil level, and it is fine. No apparent leaks. So I waited another 3 or so minutes, and took off again. Same thing happened, the oil warning light came on, but I drove through it. After about 2 minutes of driving the knocking decreased and everything seems fine, except it threw a check engine light flag. Is this just a cold start issue I have to be aware of, or something else? After driving for 15 minutes to get home I opened the hood again, and there may have been a slightly louder knock than usual, however it may just be my imagination.
Any advice is appreciated.
Thanks!
I'd recommend bringing it to the shop. About a month ago this happened to me. It was a cold start and I got down the block when my oil pressure light came on. The engine was straining but I thought it was just the cold. About a mile later I came to a stop sign and the car stalled. Turned out I broke the tensioner, timing chain and blew the cylinder head. Audi A4.
Jonboyy055 is offline   Reply With Quote
Old 03-05-2014, 05:58 PM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
2006, a4, audi, car, check, cold, drove, engine, light, low, minutes, oil, pressure, startup, winter


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -8. The time now is 04:41 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community

Personal Contacts