Go Back   AudiWorld Forums > Audi Models > Audi A6 / S6 / RS 6 > A6 / S6 (C6 Platform) Discussion
Sign in using an external account
Register Forgot Password?

Notices

A6 / S6 (C6 Platform) Discussion Discussion forum for the C6 Audi A6 produced from 2004-present and Audi S6 produced from 2007-present

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 01-14-2011, 04:58 AM   #1
vlam04
Audiworld Junior Member
Account #: 170912
 
Join Date: Oct 2009
Posts: 53
Default 2006 A6 P2006 P2007 Error Code

Hey gang,
So my check engline light came on and I had my indie look at it. they do a pretty good job and are reasonably priced. he said that the error code is p2006 and p2007 which is related to the intake flaps not opening or there is a vacuum leak somewhere involving the inlet manifold. he said that the drive unit for it is malfunctioning. the part alone is like $350! part number is 06e-133-619. and to install it is like $225. i didn't realize this was going to be so hard to install that the price would be so high.

has anyone else had this problem? i read somewhere that this could also be related to carbon build up inside the engine and that our 3.2 engines are notorious for carbon build up. boooo!!!

-van
vlam04 is offline   Reply With Quote
Old 01-14-2011, 09:38 PM   #2
A6Gary
AudiWorld Super User
Account #: 49976
 
Join Date: Jan 2003
Posts: 5,468
Default

You can purchase that OEM part on–line for $259.20 + $5.95 shipping from audipartsnationwide.com (Rector Audi). BTW, I have not had any issues (at least not yet) with my 2006 A6 Avant w/ 43K miles on it.
A6Gary is offline   Reply With Quote
Old 01-17-2011, 06:01 AM   #3
badziewo
Audiworld Junior Member
Account #: 186983
 
Join Date: Jun 2010
Posts: 40
Default

I had exactly the same problem code P2006, P2007.
One of the vacuum pipe in the front of the engine was cracked.
The pipe cost me $21 from audi
badziewo is offline   Reply With Quote
Old 01-18-2011, 07:36 AM   #4
vlam04
Audiworld Junior Member
Account #: 170912
 
Join Date: Oct 2009
Posts: 53
Default

hey badziewo or anyone else.... do you know where i can locate the vacuum line? my i'm hoping it's just the hose or vacuum line that i can inspect myself.
vlam04 is offline   Reply With Quote
Old 01-19-2011, 05:25 PM   #5
badziewo
Audiworld Junior Member
Account #: 186983
 
Join Date: Jun 2010
Posts: 40
Default

The vacuum pipes are located under the front engine plastic cover.Check the TSB attachment
Attached Files
File Type: pdf How To Vacuum Leak.pdf (828.6 KB, 468 views)
badziewo is offline   Reply With Quote
Old 02-04-2012, 12:23 PM   #6
rgarretson
Audiworld Junior Member
Account #: 175160
 
rgarretson's Avatar
 
Join Date: Dec 2009
Posts: 47
Default

Thanks guys, with your thread I was able to search for the proper vacuum hoses and sure enough, I had a broken hose. Havent fixed it just yet but now I know. I had Fault codes P2006 and P2007.
__________________
2005 A6 3.2 Quattro
Brilliant Black/Black, NAV, Sunroof, Premium Package, Technology Package
rgarretson is offline   Reply With Quote
Old 02-04-2012, 01:29 PM   #7
ezveedub
AudiWorld Senior Member
Account #: 89002
 
ezveedub's Avatar
 
Join Date: Mar 2005
Posts: 809
Default

Check the entire length of the vacuum lines, as they break over on the driver's side front area of the cylinder head also. You can generally clip the brittle section out and use a rubber vacuum hose in that area instead.
ezveedub is offline   Reply With Quote
Old 02-10-2012, 03:35 AM   #8
rgarretson
Audiworld Junior Member
Account #: 175160
 
rgarretson's Avatar
 
Join Date: Dec 2009
Posts: 47
Default

Hey guys, Quick question. I took the advie and replaced the entire length of the side that I found broken with heat resistant silcone/rubber hose. It might be my imagination but the car appears to respond better however the engine light did not go off on its own. Do I need to get the codes cleared or will the light go off on its only after a little while?

Thanks
__________________
2005 A6 3.2 Quattro
Brilliant Black/Black, NAV, Sunroof, Premium Package, Technology Package
rgarretson is offline   Reply With Quote
Old 02-10-2012, 04:10 PM   #9
MaydayNY
Audiworld Junior Member
Account #: 225264
 
Join Date: Nov 2011
Posts: 12
Default

Same thing happened to me. Took about a day, but the light eventually went out on its own.
MaydayNY is offline   Reply With Quote
Old 04-29-2012, 05:16 PM   #10
Fitness09
AudiWorld Newcomer
Account #: 235097
 
Join Date: Apr 2012
Posts: 1
Default Looking at a 2006 A6

I am currently looking at purchasing an Audi A6, but wanted to get a take from some owners. It is a 2006 3.2 and looks to have all the options. However, there are some problems. It has 71k miles on it, it is sending the code about the cracked hose mentioned in this thread, one rear light is out, the passenger side window will roll down, but not up from the driver side(it will from the passenger side door), and the air bag light is on. The girl who currently own the car said the airbag light has come on and off since she bought it.

This is a pretty nice vehicle, but I don't want to buy a problem. Thanks for the help.
Fitness09 is offline   Reply With Quote
Old 04-29-2012, 05:16 PM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
07, 2005, 2006, 2007, a6, audi, code, codes, ecu, engine, error, fault, number, p2006, p2007


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -8. The time now is 11:05 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community

Personal Contacts