Go Back   AudiWorld Forums > Audi Models > Audi A4 > A4 (B6 Platform) Discussion
Sign in using an external account
Register Forgot Password?

Notices

A4 (B6 Platform) Discussion Discussion forum for the B6 Audi A4 produced from 2002-2005

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-27-2008, 08:06 PM   #1
WoodyS
Audiworld Junior Member
Account #: 77946
 
Join Date: Jul 2004
Posts: 24
Default CEL - OBD II code P0050

My daughter's 2002 A4 (60K miles) CEL has been on for a few weeks. We read the code (P0050 - O2 sensor heater circuit bank 2 sensor 1) and replaced the O2 sensor. (What a job! But that's another story.)

I disconnected the battery to reset the memory, but the code returned quickly. I then had the code read a second time, with the same result, P0050. This time I had the OBD memory reset by the code reader. The CEL was out for a short time, but next time the engine was started cold, the code again returned.

I'm stumped. Can anyone suggest what else I should look for?
WoodyS is offline   Reply With Quote
Old 07-28-2008, 06:42 AM   #2
quattrothatcould
AudiWorld Super User
Account #: 105649
 
Join Date: Mar 2006
Posts: 12,794
Default Is there a connection loose between the O2 sensor and the connector?

Cracked wire or something that would throw the same code?
__________________
-Matt



2004 Audi A4 1.8t 6MT Quattro

"Modding is like herpes; once you get the itch, it never leaves."- OpenSkye

Dahlback | Milltek | AWE | Vogtland | H-Sport | Oettinger | BFGoodrich | Thule | OEM+ | Dents

Wish List: Stasis Torsen Center Differential, S4 Recaros (Black leather), Affordable parking in Washington DC

KMD Tuning

Stock Dyno (w/ Milltek): 162.5 HP; 164.5 ft/lbs TQ

Dahlback Stage 2 Dyno (w/ AWE FMIC, Milltek): 244.8 HP; 312.8 ft/lbs TQ

2002 Audi 1.8t K04'd Tiptronic
Gone but not forgotten
quattrothatcould is offline   Reply With Quote
Old 07-28-2008, 06:42 AM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
0050, 02, 2002, a4, a6, audi, circuit, code, forums, heater, obd, obd2, odb, p0050, reset


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -8. The time now is 03:15 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community

Personal Contacts