Go Back   AudiWorld Forums > Audi Models > Audi A6 / S6 / RS 6 > A6 / S6 (C5 Platform) Discussion
Sign in using an external account
Register Forgot Password?


A6 / S6 (C5 Platform) Discussion Discussion forum for the C5 Audi A6 and S6 produced from 1998-2004

Welcome to AudiWorld Forums!
Welcome to AudiWorld.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the AudiWorld Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 10-04-2013, 07:00 PM   #1
Audiworld Junior Member
Account #: 264209
 
Join Date: Aug 2013
Posts: 59
Default speedometer stopped working....WTF

2004 Audi A6 2.7t quattro automatic..161,000 miles...the speedometer stopped and i ran codes and it said VSS , replaced and it still doesnt work...its so weird cause it will jump around one minute and then stay stuck on 0, then it may work for 30 minutes then stop again.....what the hell can it be?
jimmyjames72 is offline   Reply With Quote
Old 10-04-2013, 07:48 PM   #2
AudiWorld Member
Account #: 171699
 
tester123's Avatar
 
Join Date: Oct 2009
Posts: 487
Default

Quote:
Originally Posted by jimmyjames72 View Post
2004 Audi A6 2.7t quattro automatic..161,000 miles...the speedometer stopped and i ran codes and it said VSS , replaced and it still doesnt work...its so weird cause it will jump around one minute and then stay stuck on 0, then it may work for 30 minutes then stop again.....what the hell can it be?
possible intermittent wiring / loose contact issues..?
__________________
ʘ˥ Pearl White А6 Ч.2ℓ Quattro
Sport, cold, everything -Nav.
▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫
No more OIL or COOLANT leaks! │ T-Belt, Water pump & Valve Covers DONE! │ Trans & Diff Fluid DONE! │ Bearing & Inner Tie-rod Next │ Steering leaks?
Fuel Banks 1 & 2 Lean issue fixed (finally!)
Rebuild Bosch 150 Amp Alternator (save major $$$)
tester123 is offline   Reply With Quote
Old 10-04-2013, 08:00 PM   #3
Audiworld Junior Member
Account #: 264209
 
Join Date: Aug 2013
Posts: 59
Default

loose contact wires where?
jimmyjames72 is offline   Reply With Quote
Old 10-05-2013, 12:49 AM   #4
Audiworld Junior Member
Account #: 260385
 
Join Date: Jun 2013
Posts: 39
Default

Is every other gauge and light in the cluster functioning properly? I had a B5 A4 that had a flickering speedo needle. It got worse and worse and eventually stopped altogether. When the headlights were turned on the dash went completely dead and the all illuminated buttons on the interior went off e.g window buttons etc. I had to replace the dash to fix that problem
nzaudia6 is offline   Reply With Quote
Old 10-05-2013, 06:00 AM   #5
Audiworld Junior Member
Account #: 264209
 
Join Date: Aug 2013
Posts: 59
Default

everything works fine except the speedo and then in turnmesses up the gas gauge and the odometer also.....what can this be...before i have to go to audi dealer.....
jimmyjames72 is offline   Reply With Quote
Old 10-05-2013, 07:36 AM   #6
AudiWorld Member
Account #: 171699
 
tester123's Avatar
 
Join Date: Oct 2009
Posts: 487
Default

from vss and possibly behind the instrument cluster... Scanned to see any codes?
__________________
ʘ˥ Pearl White А6 Ч.2ℓ Quattro
Sport, cold, everything -Nav.
▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫
No more OIL or COOLANT leaks! │ T-Belt, Water pump & Valve Covers DONE! │ Trans & Diff Fluid DONE! │ Bearing & Inner Tie-rod Next │ Steering leaks?
Fuel Banks 1 & 2 Lean issue fixed (finally!)
Rebuild Bosch 150 Amp Alternator (save major $$$)
tester123 is offline   Reply With Quote
Old 10-05-2013, 08:15 AM   #7
Audiworld Junior Member
Account #: 264209
 
Join Date: Aug 2013
Posts: 59
Default

yeah the code it ran was calling for the VSS to be changed...i changed that and it still didnt work....some said the cluster has to be changed...but there is something like an imobilizer associated with that.
jimmyjames72 is offline   Reply With Quote
Old 10-05-2013, 09:39 AM   #8
AudiWorld Senior Member
Account #: 220156
 
Join Date: Aug 2011
Posts: 1,542
Default

The instrument cluster gets the VSS signal, then sends it to the ECU which will set a code. It is not getting VSS, because the instrument cluster has failed. Its not uncommon to have the electronic speedometers fail.
__________________
1991 Audi 200 Turbo
1999 Audi A6 Avant 2.8
1998 Audi A4 quattro 1.8T
Prospeeder is offline   Reply With Quote
Old 10-05-2013, 01:13 PM   #9
Audiworld Junior Member
Account #: 264209
 
Join Date: Aug 2013
Posts: 59
Default

so if i have to replace the speedometer cluster, is something you can do yourself? it lookds fairly simple...a few screws in the front and it comes right out..or is this an expensive job for an audi dealer to do?
jimmyjames72 is offline   Reply With Quote
Old 10-05-2013, 03:17 PM   #10
AudiWorld Member
Account #: 171699
 
tester123's Avatar
 
Join Date: Oct 2009
Posts: 487
Default

Just found out in the manual:


The Immobilizer is a theft-deterrent device that adds a layer of security that is standard on every Volkswagen and Audi model. This is achieved with an electronic device embedded in the ignition key, an Immobilizer Control Module and an electronic link to the Engine Control Module.



Working with Immobilizer Systems

Audi limits access to certain functions by requiring a Personal Identification Number (PIN).

PINs are required for the following functions:

Adding new keys

Replacing lost keys

Replacing Instrument clusters

Replacing Engine Control Modules

Other repairs to the Immobilizer system



GeKo

Audi uses an on-line Immobilizer Adaptation (PIN) delivery system, known as GeKo. GeKo is a vehicle anti-theft protection system. With this system, the VAS 5051 or VAS 5052 diagnostic tester is connected to the vehicle and via Internet to an online database called Fazit. The identification of the tester and vehicle are passed to the database and the correct PIN is passed to the vehicle in a secure link without direct user interface.
__________________
ʘ˥ Pearl White А6 Ч.2ℓ Quattro
Sport, cold, everything -Nav.
▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫▫
No more OIL or COOLANT leaks! │ T-Belt, Water pump & Valve Covers DONE! │ Trans & Diff Fluid DONE! │ Bearing & Inner Tie-rod Next │ Steering leaks?
Fuel Banks 1 & 2 Lean issue fixed (finally!)
Rebuild Bosch 150 Amp Alternator (save major $$$)
tester123 is offline   Reply With Quote
Old 10-05-2013, 03:17 PM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
1999, 2004, a6, audi, quattro, quit, speedometer, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:34 AM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community

Personal Contacts

SEO by vBSEO ©2011, Crawlability, Inc.