Go Back   AudiWorld Forums > Audi Models > Audi A4 > A4 Cabriolet (B6 Platform) Discussion
Sign in using an external account
Register Forgot Password?


A4 Cabriolet (B6 Platform) Discussion Discussion forum for the B6 Audi A4 Cabriolet

Welcome to AudiWorld Forums!
Welcome to AudiWorld.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the AudiWorld Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 09-08-2012, 09:07 AM   #1
AudiWorld Newcomer
Account #: 242711
 
Join Date: Sep 2012
Posts: 4
Default Left side turn signals don't work--right side does....Relay location?

All--I have a 2004 Audi A4 Quattro Cabriolet 3.0 6-cyl [B6] and the left turn signal (neither front or rear) will work, but the right side turn signals work and the emergency flashers work. When the flashers are on, the left side signals light up, so i know that the bulbs are fine in both. I saw that there is no fuse for the B6 and the relay for the B6 is not the same for the B5 (Note: The B5 is a simple repair--just take out the emergency flasher unit from the dashboard with a small flathead screwdriver and either clean the contacts or pay under $50 (incl. shipping) for the new relay from a reputable online vendor.]

I would like to locate the turn signal relay for the B6 and try to either clean the contacts or replace the unit, if need be. Any help would be most appreciated--THX!
snakelegs is offline   Reply With Quote
Old 09-11-2012, 08:41 AM   #2
Former Vendor
Account #: 195379
 
Join Date: Oct 2010
Posts: 189
Default

Alldatadiy.com has symptom related information that could assist in your search for the answers. Good luck!
ALLDATAdiy INFO is offline   Reply With Quote
Old 09-25-2012, 05:59 PM   #3
AudiWorld Newcomer
Account #: 242711
 
Join Date: Sep 2012
Posts: 4
Default

Really? I need a simple location identified.....not an ad! Good grief! Can anyone help--please?
snakelegs is offline   Reply With Quote
Old 09-28-2012, 10:35 AM   #4
Audiworld Junior Member
Account #: 240455
 
Join Date: Aug 2012
Posts: 11
Default

Did you get this fixed? Having same problem. Also, now saying brake light on my dash indicator
audicabrio303 is offline   Reply With Quote
Old 09-28-2012, 10:36 AM   #5
Audiworld Junior Member
Account #: 240455
 
Join Date: Aug 2012
Posts: 11
Default

Quote:
Originally Posted by snakelegs View Post
All--I have a 2004 Audi A4 Quattro Cabriolet 3.0 6-cyl [B6] and the left turn signal (neither front or rear) will work, but the right side turn signals work and the emergency flashers work. When the flashers are on, the left side signals light up, so i know that the bulbs are fine in both. I saw that there is no fuse for the B6 and the relay for the B6 is not the same for the B5 (Note: The B5 is a simple repair--just take out the emergency flasher unit from the dashboard with a small flathead screwdriver and either clean the contacts or pay under $50 (incl. shipping) for the new relay from a reputable online vendor.]

I would like to locate the turn signal relay for the B6 and try to either clean the contacts or replace the unit, if need be. Any help would be most appreciated--THX!
Were you able to get this resolved? I'm having the same issue. Now, the brake light indicator is also showing up on my dash.
audicabrio303 is offline   Reply With Quote
Old 10-01-2012, 04:06 PM   #6
AudiWorld Newcomer
Account #: 242711
 
Join Date: Sep 2012
Posts: 4
Default

Quote:
Originally Posted by audicabrio303 View Post
Did you get this fixed? Having same problem. Also, now saying brake light on my dash indicator
I have not (yet) received an answer from this forum (or any other I have posted this issue on). To confirm, we are also seeing the 'BRAKE' message pop up as well....it pops up intermittently. We have a short time before we have to get the car inspected and it will, obviously, not pass its inspection without left turn signals. Honestly, I would have thought that at least one of the two Audi forums would have had this one nailed by now. Can anyone locate the turn signal relay for a 2004 Audi A4 (B6) Quattro Cabriolet 3.0L?? Anyone? I even bought a Haynes manual and even that didn't help with this issue--not at all! Your help is most appreciated! Thank you!
snakelegs is offline   Reply With Quote
Old 12-24-2012, 07:53 AM   #7
Audiworld Junior Member
Account #: 240455
 
Join Date: Aug 2012
Posts: 11
Default

Quote:
Originally Posted by snakelegs View Post
I have not (yet) received an answer from this forum (or any other I have posted this issue on). To confirm, we are also seeing the 'BRAKE' message pop up as well....it pops up intermittently. We have a short time before we have to get the car inspected and it will, obviously, not pass its inspection without left turn signals. Honestly, I would have thought that at least one of the two Audi forums would have had this one nailed by now. Can anyone locate the turn signal relay for a 2004 Audi A4 (B6) Quattro Cabriolet 3.0L?? Anyone? I even bought a Haynes manual and even that didn't help with this issue--not at all! Your help is most appreciated! Thank you!
Did you get this resolved? After some time all of the running lights on the driver side stopped working, headlight included. I had to have a direct line wired to the lights for them to work.
audicabrio303 is offline   Reply With Quote
Old 07-21-2014, 01:09 AM   #8
AudiWorld Newcomer
Account #: 254610
 
Join Date: Mar 2013
Posts: 1
Default

Sorry to necro this thread but I have been searching everywhere to find a solution and still haven't found it. This is one of those threads I've stumbled upon.
Chavez Jose is offline   Reply With Quote
Old 07-29-2014, 08:36 AM   #9
AudiWorld Newcomer
Account #: 242711
 
Join Date: Sep 2012
Posts: 4
Default Problem resolved, but it took a mechanic to do it...

Quote:
Originally Posted by Chavez Jose View Post
Sorry to necro this thread but I have been searching everywhere to find a solution and still haven't found it. This is one of those threads I've stumbled upon.

ALL--This problem was resolved by taking it to Dave Planakis from Capitol Car Care, Stafford, Virginia. Dave fixed it for us, although we can't remember exactly what he had to do to fix it. The next tie we see him, we'll ask and re-post. THX!
snakelegs is offline   Reply With Quote
Old 07-29-2014, 08:36 AM
AudiWorld
Audi R8




Paid Advertisement
 
 
 
Reply

Tags
1997, 30, a4, audi, b6, dont, fuse, left, relay, replacement, side, signal, signals, turn, work


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:42 PM.


Copyright 2014 AudiWorld.com Audi Enthusiast Community

Personal Contacts

SEO by vBSEO ©2011, Crawlability, Inc.